Friday, October 25, 2013

Patcher Update

As many of you have noticed in the past few weeks, the patcher got broken... This was actually pretty normal to happen at one point, the same happened with the version 5.2 patcher and the same would have happened in the future.

Now, I'm not good with this stuff so I can't explain it perfectly but basically the web host on which the mod was hosted for updates has an IP change from time to time and so it brakes the patcher.
We looked for alternative hosts but couldn't find anything good for free, because, well, a paid host was not a very appealing option for me for several reasons.

Anyhow, after a lot of searching, testing and work on the patcher itself, Shyke, the programmer which made the patcher and to which I am owe a lot for his help, said we should use GitHub and so we did.

The result? A new patcher which downloads and updates the mod faster but takes a bit longer to set up the first time you run it. After that first time everything should be fast and clean. Well, maybe not that clean, the patcher will make some additional folders and files inside AoE3 in order to function as it is, but it's nothing to worry about.

So, download the newest patcher version, put it where you have the game installed, run it (as administrator) and update!
How can you know if it worked? Simple, I've added some new gameplay soundtracks, so go start a skirmish match and listen if the first song you hear is new! Also tell me if you like it, I found it on YouTube and maybe you think it doesn't fit the game very well.

Thank you everyone for playing and many thanks to Shyke for his amazing work!


Because of obvious reasons I now have to put the UI warning/fix in every new post that I make so I'll have less people asking me all the time how to fix the resource icons being messed up...

If you have problems with the UI not displaying resources correctly go to "Options" and press the "Restore Defaults" button!

35 comments:

  1. Ok, we'll wait then, no problem!
    Again, thank you for your great job!!

    ReplyDelete
    Replies
    1. Its fixed! Read the post again so you'll know how to get it working properly.

      Delete
    2. Nah, this time Shyke, the patcher's programmer takes all the credit, I just try to help him.

      I hope you'll like the new soundtracks! :)

      Delete
    3. I really don't understand what's going on, I came here because patcher was going online and not finding anything for a halfhour. Then even the new patcher is doing the same thing. Anyone have an idea on something I haven't thought about trying? I have no firewall up software or hardware. I have avg disabled. I tried running as admin. AoE3ImpModPatcher.exe does nothing not even warn IMGUR here: http://i.imgur.com/j7ceTVp.png

      Delete
    4. That image is not helpful at all. I need to see if its in the right place, if you have all expansions, something, anything!
      Have you ran the patcher as admin?

      Delete
    5. Oh shoot sorry was so frustrated that I jotted the comment. I ran it as admin[right clicking file in win7] while it was in the main directory with the executables; vanilla exe as well as expansion exe's X and Y.
      The green progress slides but nothing happens. It just stays searching with no time out. I have to end up just stopping it.
      It worked previously.

      Delete
    6. Uf.... How do you people keep running into trouble when everything works.
      Nothing else to do except for me to have a look with Team Viewer. Are you willing to let me?

      Delete
    7. No that would be great. And if you celebrate today Happy today! It's actually 6am here now so I am off to bed. Played two long games of AOE3. Let me know when you're free.

      Delete
    8. Your response was confusing, so you want to let me have a look?
      Well then if you do go to the "Help and Tools" tab here on the blog and look out for IDs to contact me.

      Delete
  2. I can't find this .git folder in the age of empires 3 folder... Maybe I missed it, but I can't find this folder. Loved the mod, but with my current version it's too bugged to play. Thanks in advance!

    ReplyDelete
    Replies
    1. "too bugged"???

      Even with version 5.2 it shouldn't be "too bugged".
      Can you maybe share these bugs so I can fix them?

      Delete
  3. Hi, is it normal for the icons of the resources to be switched around I.E. food has the wood icon, wood has the gold icon etc.? Also, the patcher doesn't seen to be able to connect to your server, I have Run as Admin and disabled anti-virus

    ReplyDelete
    Replies
    1. ... On the right side of the blog, can you read that?

      "If you have problems with the UI not displaying resources correctly go to "Options" and press the "Restore Defaults" button!"

      Delete
    2. Do I really need to put that message everywhere?

      Delete
    3. Sorry for that, thanks so much though! Cant believe I didn't see that.

      Delete
    4. What about the patcher? it just says checking for updates continuously.

      Delete
    5. I just checked, there's nothing wrong with it. Do you have the latest version presented here? Did you ran it as administrator?

      Delete
    6. Yes, sorry for super late reply, i have done both of htose things. In the end, I just scoured github for all files relating to this mod, and installed them. There was only three repositories right?

      Delete
  4. Patcher won't work. After searching, it displays message that it can't grab data, and patcher exe turns to "AoE3ImpModPatcher.exe_bk". I cannot start it again.

    ReplyDelete
    Replies
    1. Just checked it, it works, its just you who can't get it right.

      Download the new patcher, put it in the main AoE3 folder, run as admin.
      If it still doesn't work contact me via Skype or Steam, details here:
      http://impmod.blogspot.ro/p/help-and-tools.html

      Delete
  5. you can have the manual patch exe not my mod works with modloader exe

    ReplyDelete
    Replies
    1. Every installer release comes with a manual installation version, but, updates released through the patcher do not have any manual version UNTIL they are released as a full, new update tagged with a version like let's say 5.5.

      So, if you're using the modloader you must wait until version 5.5, or something, I don't really know how the modloader works.

      Delete
  6. Ehy man, since the last update i noticed low FPS in "online" multiplayer match only, the game is kinda stuck at 30 FPS, but FRAPS tells me i have 120FPS (as normal), so i think that is the mod to limit this... could you fix this?
    KEEP IT UP!! ;) love this mod <3

    ReplyDelete
    Replies
    1. What... I've done absolutely nothing to cause this, I didn't touched graphics, textures, nothing. Tell me what's on your screen when you get low fps, what units, buildings, I dunno, something to actually help me.

      Delete
    2. The problem is not the units on screen, in fact the fps seem to be stuck at 30 even at the very beginning of a match.. and i say "seem" because all "FPS on screen" programs, like MSI Afterburner, Dxtory or FRAPS; all of them show that the game, in reality, is running at 120fps... WTF
      I don't know, maybe is Game Ranger? I use it for play in Multiplayer...

      Delete
    3. No idea, and if no one else reports this then I'll assume its only on your side.
      Wait, you said multiplayer right? Well then that's just pure, good old lag (latency) dude, one of the players has a shitty internet connection.
      That's all I can tell you, sorry.

      Delete
  7. after i ran the mod my TAD shortcut died on the desktop... so I went to the installed folder and searched the exe for TAD but am unable to find it... boss, I only want to play TAD and not the other warchiefs and AOE3... can you please tell me what went wrong... and where can I find my TAD...please reply dear... waiting...

    ReplyDelete
    Replies
    1. Well, if you installed everything correctly including the mod then you should run the mod;s patcher and the exe should be back.
      In case it doesn't come back for some weird reason you can get it from here:
      https://www.dropbox.com/s/nvoq4f69o2r1ken/aoe3_official_exes.zip

      Delete
  8. This comment has been removed by the author.

    ReplyDelete
  9. Polish translation for recent update (07.01.2014): http://www31.zippyshare.com/v/5ua3az6C/file.html Everything added/changed by mod is translated, though, i don't know if there are some other files beside stringtabley.xml which should be translated

    ReplyDelete
    Replies
    1. http://speedy.sh/gkRCd/ImprovementMod-PL-v.14.01.07.alpha.zip mirror

      Delete
    2. Oh cool! I hope you understand my mod makes more changes to "stringtabley" than you see at the end of the file, right?
      As for if its the only file, well there are still a few words that will be in english, like some UI elements and maybe some campaign stuff, but only a few and its easier to just translate "stringtabley" alone.

      Now, I recommend you use Dropbox to upload the file because if I update the mod you will be able to update the file on Dropbox without the link changing, just like the german translation works, have a look at it.
      Unless ZippyShare allows you to do the same thing, I don't know.
      Otherwise, every time I release an update you will need to contact me so I can change the link and, well I like everything to be automated, to work without me.

      So please, use Dropbox for this, and thank you for your awesome contribution!

      Delete