Downloads

This mod started out as a 'Buildings Mod', with the objective to add more nice and useful buildings to the game, but many more improvements where needed and many ideas where coming so the 'Improvement Mod' was born.
The mod upgrades the game with small and big changes alike, as well as necessary tweaks and adds to make the gameplay more complex, realistic, interesting, fun and challenging. All known bugs from the original game have been fixed.
More great things to come!

Requirements: This mod is only for The Asian Dynasties but requires AOE3+TWC+TAD 1.03

Special thanks to everyone who helped me improve the mod.

Notice that some units or buildings present in this mod are taken from the Napoleonic Era or War of the Triple Alliance mods.

----------------------------------------------------------------------------------------------

Every version of this mod should be installed on a fresh, unmodified version of  'Age of Empires 3 The Asian Dynasties' (must also include 'The War Chiefs' and all games must be updated to the latest versions, v1.03 for TAD)! Mostly recommended only if you have any kind of errors or other problems.

If you have problems with missing models, sounds or buildings icons then try to re-install 'The War Chiefs'. It has some installation glitches.
And if that doesn't work then find out how to fix it at the end of this description.

High video settings are recommended for all visual changes to work properly.

Please do not 'update' the mod with any rip-offs or other modifications from mods 'designed' to work with this one.

The mod is officially available only in English but you can also get it to work in French and German (fan made), though its not recommended because they may contain inconsistencies.

Requirements: This mod is only for The Asian Dynasties but requires AOE3+TWC+TAD 1.03

For the latest official patches go HERE!
Or download them from HERE!

----------------------------------------------------------------------------------------------


-----------------------------------------------

----------------------------------------------------------------------------------------------

I understand that THIS! torrent contains the game with both expansions and fully updated, so download it if you don't have the game, install it and apply the mod.

Download the mod's patcher from HERE! It can be used on a fresh installation to fully download and install the mod.
Just drop it in your AoE3 main directory and run it as administrator, it will check for the latest version and update if necessary.

The mod works on both the pirated version and the genuine version of the game (Steam and non-Steam), also please note that the mod does not require to be run from the patcher every time, the patcher is only for updating, you can start the game normally via the TAD exe and the mod will still be there.

If you've installed the mod with the patcher and the American (USA) civ is missing then download THIS! and follow the instructions inside.

Un/Installation
- make sure you have the latest versions of all 3 games (v1.03 for TAD), get the latest patches from the game's official website or use the game's updaters
- run the installer, select your AoE3 directory and continue with the installation
- to completely remove the mod please re-install the game

Manual Install
- copy everything from inside the 'improvement_mod' folder to your AoE3 directory, and everything from inside the 'usa_civ' folder to 'My Documents'

Steam
- if you plan on installing this mod over the Steam version, use this path for the installer:
/Steam/steamapps/common/Age of Empires 3/bin/

Noob Translation
1. Install Age of Empires 3 (do not install any cracks after you finish, you just need a serial)
2. Install The WarChiefs (watch out what version of this one you install, some are broken)
3. Install The Asian Dynasties (try not to run any of them until you complete all steps)
4. Update Age of Empires 3 (latest version: 1.14)
5. Update The WarChiefs (latest version: 1.06)
6. Update The Asian Dynasties (latest version: 1.03)
7. Install mod and run the patcher to update (run as administrator)

115 comments:

  1. I'm really enjoying the mod. Is there a forum or a thread where people discuss the ins and out of the mod,and the different strategies they use?

    ReplyDelete
    Replies
    1. Thank you for the support, but sadly I do not have a forum... yet...
      I mean, I wanted to make one but I feared no one would use it...

      But, I will make a survey and ask people what they think, if I should make one. And if the answer is yes, I might need some moderators, maybe you're interested?

      Delete
  2. Way, way too much of newb to even be considered, but thanks for the offer. Still, keep us posted on what is going on!

    ReplyDelete
  3. alright so i love your mod WHEN IT WORKS! thats the hard part... i have spent easily over 10 hours trying to get this mod perfectly installed. but let me get to the point. i believe your problem is with your "AoE3ImpModPatcher" i can get the Mod working all fine and dandy but when i run the patcher it corrups my original age3 game and when i try to run it it just gives me an error stating "initialization Failed" and when i try to open war chiefs it says "initialization Failed Could not load DATAPX.BAR" its a pain... becuase i love the mod though not all of my freinds have it so i cant play the normal version with them

    ReplyDelete
    Replies
    1. Hm, it might be indeed the patcher.
      But as long as no one else reports this, I will say it's isolated to your PC.
      Over time people reported "GODZILLA" like problems, when in fact it were just minor misunderstandings.

      What would help both of us, and especially everyone that plays the mod, would be if you contact me on Skype and let me see the problem for my self with Team Viewer, I can also look at the patcher and see if it's working as it should, and check other files for consistency.

      That is, if you want to help.
      My Skype ID is "mandos-rex" if you're interested.
      I will check everything to be sure.

      Delete
    2. I ran into this same problem. I played the game for a while, was having a blast. I got well into the Blood, Ice and Steel campaign. I quit and when I came back to play later on it gave me that error. Well I uninstalled everything and reinstalled from scratch, then my save from the campaign didn't show up. So I scrapped that and said, "Oh well, I'll start over." And the second map on Act 1 would not load. It kept saying, "campaign/age302m failed to load." I searched in the save folder and the game folder and could find no such file with "age302m" or "302m" in the name. I reinstalled from scratch AGAIN without your mod and it's working fine now. Any idea what could be the problem? If you need any more info let me know, I really loved playing with the mod. Thanks —

      Delete
    3. Oh, so a problem with a scenario. No problem, I will fix it right away.

      Delete
    4. I've checked the scenario and it worked for me, nonetheless I uploaded a new version, tell me if it works for you. If you do have problems with the patcher, first of all make sure your antivirus isn't blocking it and run the patcher as admin.

      If problems don't go away then please contact me on Skype so I can further help you.

      Delete
    5. Thanks for the speedy reply. Last night I ended up using the zip version of the mod and that worked, somewhat. My tactics buttons on all of my units are missing and city cards are whacked out. Whenever I tried to use the patcher it immediately broke the campaign again. I'll try to download your new version and see if that helps. Thanks for the reply!

      Delete
    6. Well, my campaign works when I manually copy the files over. When I used the patcher, it said it updated files. But my savegame from the campaign fails to load, and so does the campaign when I try to start it. I'll try to reinstall everything from scratch again later once I have some time to fiddle with it.

      Delete
    7. Don't try old save games, they are sure not to work. This could go a lot fast and easier if you simply let me look for my self with Team Viewer to see what's wrong.
      I did this to a lot of people who had problems and most of the times I fixed them.

      Delete
    8. I suppose you could although it's not a big deal now as I've passed that campaign map and all of the others ones have worked fine. And I did find out with the save games the city cards are wonky so I know not to use them between vanilla/mod.

      Delete
    9. Hello,
      I am using the Steam Complete Version, installed your mod with the patcher, started up for the first time and also get the initialization error after the first Company Video. That is an error that should be fixed by a patch. Does your mod change something about the exe files?

      Delete
    10. It does change the exe, yes, but that shouldn't matter.
      Thing is you're the only one reporting this right now so I don't know what to tell you.

      The best way to approach this is if you let me see the error and try fixing it via Team Viewer.
      Look in the "Help and Tools" tab if you want to contact me to proceed with this idea.

      Delete
    11. The same problem for me ...i`m using STEAM Complete Version ...and get Initialization Failed after first load screen ...well while there is a solution or fix for this error ,i`ll uninnstal this great mod !!!

      Delete
    12. Aaaand now I know why. When you start the Steam Complete Collection you get 3 options, if you chose the first option, Complete Collection, that starts the normal AoE3 without any expansions (ironic, I know), the vanilla version.

      So, when starting Complete Collection from Steam you just need to chose The Asian Dynasties because that is the latest expansion and the one for which the mod was made.

      Yes, the mod breaks vanilla and The Warchiefs for reasons I do not know, but if you have The Asian Dynasties then you don't need to start the other two.

      But if you do want to play the other two then just uninstall the mod and be on your way.

      Delete
  4. For some reason on the "Pirates!" mission I start out on the "lizie's pirates" team instead of morgan black so it's completely impossible for me to get anything at all done

    ReplyDelete
    Replies
    1. Yeah... That's my bad... I will upload a fix right away.
      Be sure to report other bugs!

      Delete
  5. Hi!! First, I want to congratulate you on this great mod!! Secondly, I'm experiencing a bug with the mod patcher, it says ERROR: Could not lock files (are you playing age3.exe?). Do you know what might be the cause? I use Windows 7 64 bits.
    Lastly, could it be possible in the future to have unique textures for common units for some civs, ex. british redcoats?
    Again, congratulations and thanks for making the mod!

    ReplyDelete
    Replies
    1. The British and Dutch Imperial Musketeer skins already are different than everyone else, representing Redcoats and Stadhouders.

      The main problem is, as you can read in the latest news, the game's engine can't handle custom textures very well and creates lag and all kind of bugs, so I try to keep them to a minimum.

      You are not the first or the last to request such a thing, even I want to do it, but it simply isn't a very profitable experience.

      About the bugs, what can I say... Read the installation instructions and see if you did anything wrong. You just need the game and both expansions, all 3 updated to their latest versions, then you install the mod and that's it.

      The game+mod can still be played by running the normal TAD exe, the patcher is just for updating.

      Thank you for your time.

      Delete
    2. Hey!! Thanks for the response!! I guess that because of that error I couldn't see the redcoat texture. I'll continue trying with the patcher. Greetings!!

      Delete
  6. Do you have any other link for the Manual installation? The one you put is not working
    GREAT MOD!!!
    thanks

    ReplyDelete
  7. And I'm getting a "Could not lock files" error when I run the ImpModPatcher

    ReplyDelete
    Replies
    1. Yes, I do. Dunno what the hell is wrong with MediaFire...

      http://www.moddb.com/mods/improvement-mod/downloads/improvement-mod-version-52-manual-install

      And I can't guess what your problem is...
      Unless you contact me on Skype and let me see for my self with Team Viewer, we will just argue here and nothing will get done.

      Thank you.

      Delete
  8. For the people which get the "Could not lock the files" error:Just use those original exes and the problem is solved ;-)

    ReplyDelete
  9. I'm sorry. I'm not very computer savvy. I dont quite understand how to install the mod. I'm running AOE on Steam and I dont understand what it means to use a different path for the installer. Could you describe the installation process in more laymans terms. Thanks, Im really excited to try the mod it looks great!

    ReplyDelete
    Replies
    1. You have all the instructions you need both here on the blog and in the installer.
      Inside the Steam directory there's a folder where all games are installed. You just need to select a path inside there.

      Delete
    2. Got it! Its a beautiful mod. Thanks for making it!

      Delete
  10. It's a grat mod indeed. Much more fun to play against the AI on mid-late game.
    It uses in a significant better way their plantations and the native units, without spamming the mercenaries (especially on expert level).

    Thank you for the work tha has been done.

    ReplyDelete
  11. Hi, I installed your mod and it works great and in single player and is a massive improvement but when I try to play LAN I get a CRC mismatch error, and the config files are messed up. Is there anyway to install this so that LAN will work?

    ReplyDelete
    Replies
    1. "Config files"?
      If both you and the person you wanna play with installed the game and mod in the same way, then there shouldn't be problems.

      I't very easy to get a mismatch, check everything again.

      Delete
    2. if you want to play lan or multiplayer with friends they must have exactly the same files

      Delete
  12. I've downloaded this without having Asian Dynasties, and indeed it gave troubles. I've completely removed AOE3 (warchiefs wasn't installed), and re-installed AOE3.

    But there's still a problem occuring.
    when in-game, the sign on top of the screen which tells you what age you're in is completely black with white characters eg: discovery age - instead of the 'themeatic' bar where it is supposed to be in.
    Also, on the lower part of the screen where your recources and gatherers per recource are being displayed, it is also a completely black square, which only gives the recources, not the gatherers per recource anymore (even if I deselect and reselect the 'show gatherers per recource' in the menu).

    The answer I think is that somewhere this install is still in my files, even after complete removal of the game.

    Do you know how I can fix this?

    ReplyDelete
    Replies
    1. So now you have all 3 games...?

      Dudes, just follow the goddamn simple instructions...

      1. install AoE3
      2. install The Warchiefs
      3. install Asian Dynasties
      4. update all 3
      5. install mod
      6. optional and recommended: run the patcher to update mod

      That's it...

      Delete
    2. I only have the original and warchiefs, I DON'T have dynasties

      Delete
    3. Then it will never work...
      This is only for Asian Dynasties...

      Delete
    4. Yes, I realise this now, but it still gave me the problem with the black squares, do you know how to fix it? or maybe where it could be in my files? I've already completely removed AOE3 and reinstalled it, and even after a systemrecovery from before the download, those black bastards are still there..

      Delete
  13. This comment has been removed by the author.

    ReplyDelete
    Replies
    1. This comment has been removed by the author.

      Delete
  14. when is the new vertion of the mod release?

    ReplyDelete
  15. Any chance of this ever making it's way to Mac? My friend has it for Mac, and was wondering.

    ReplyDelete
    Replies
    1. You can install it for Mac my friend.
      If you don't have the thing to run exes then get the manual installation version and just drop the files in the AoE3 folder.

      Hm... But now that I think about it, the next update will also include a modified exe so I donno... Never had a Mac in my hands so I have no idea but I do know there is something that Macs can get to run exes.

      Delete
  16. I got a problem with US Civ, the envoy is invisible so how can I gather fame!

    ReplyDelete
  17. ı can't age up
    when ı come age 2 ı can't advance age 3 no politicans in the screen

    ReplyDelete
    Replies
    1. Right... Well, since you're the only one with this problem how am I suppose to fix it...?

      Please check your installation.

      Delete
  18. in americans ı can't use consulate because there aren't export and all envoys speak dutch

    ReplyDelete
    Replies
    1. And that is why the USA lost support, which means I won't be working on them anymore because I can't make them to work perfectly.

      Delete
  19. AI doesn't gather fame and doesn't train envoy without Dutch

    ReplyDelete
    Replies
    1. Of course it doesn't, I have no idea how to do it... XD

      Delete
    2. Scrap that, I made the AI to train Envoys and gather fame with them.

      Delete
  20. hi there..

    why is it after i installed this great mod..the AI seems to get passive and wont advance to the next age?

    ReplyDelete
    Replies
    1. Well, the AI has different tactics now. Its true that some are a bit shitty, but play on hard or expert and they should do well.

      Thanks for playing.

      Delete
  21. Hey Mandos, i have have a problem with the uninstall. I tried to reset my account, not because the mod is bad, but it still will not let me play Nilla AoE because I get "initialization error" nothing else included in there just a black screen and that error. I also get CRC Mismatch online on TAD, the only one in the series that works right now. Please Help!

    ReplyDelete
  22. Well, I fixed it myself. I simply deleted all trace of the game off my computer, such as checking the "Remove Saved Games" box and deleting registry.

    ReplyDelete
    Replies
    1. Exactly. A simple uninstallation doesn't remove the mod entirely. After you uninstall the game you have to delete the folder where it was installed.

      Sorry I couldn't respond faster.

      Delete
    2. Its all good I was just impatient XD and I didn't want to get rid of my saved games. Great mod btw

      Delete
  23. Hi! I have AOE Complete through Steam and so does my buddy. We both downloaded it and then applied the MOD exactly the same. For some reaosn my Fame is my population, my food is always 0(fame), my wood is food, and so on.

    help?

    ReplyDelete
    Replies
    1. More details please...

      Only you have this problem and your friend doesn't?
      Can you play multiplayer with him? If it gives you an error then something is wrong with your installation.
      Did you run the mod's patcher?

      If you can't fix it please contact me on Skype at this ID: mandos-rex

      Delete
  24. i cant play the us on map editor. it will allow me to fix there hc cards but when i build a deck a go to play test the map i can use the deck i use. can you help me fix this plz. this mod is great me and a friend play this mod all the time if you can help me that would be great

    ReplyDelete
    Replies
    1. Sadly, you cannot play with player made civs in the Editor. I know it sucks, but its a game bug and I can't fix it.
      Sorry.

      What you can do is to use the vanilla Act3 US civ which is the same as the one I made, its called United States and its right under Knights of St. John and Black's Mercenaries.

      Delete
  25. i tryed but it just like yours but home city editor civ does not work and i cant build a deck for the us it gives me a 5 card deck

    ReplyDelete
  26. AMAZING!!! This mod works perfectly and it is AWESOME!!!
    THANK YOU SO MUCH for the mod and the full game! (I have bought the game but without expansions so I had to download this one)
    THANK YOU THANK YOU THANK YOU!!!!!!

    ReplyDelete
  27. Hey, I was wondering since I'm playing on my MacBook Pro.

    I installed all 3 games in my Mac HD.
    I'm I suppose to put the files in the original AoE3 or TAD folder?
    One more thing, I play using TAD to start, no launcher.

    ReplyDelete
    Replies
    1. Update: I followed your instructions, but unfortunately, the popup says TAD was unable to initialize. Got passed the intro, then it failed.

      Delete
    2. Uhm... Something tells me your installation is a mess. And what do you mean by "AoE3 or TAD folder", they use the same folders...

      Do you have The Warchiefs expansion also? Did you installed the updates? Did you used any cracks? There are many things which could have gone wrong but at the same time the installations is extremely simple.

      Delete
  28. i'd downloaded aoe 3 full collection, and extracted the files, and copy the aoe 3 file from rirectx9 to the aoe directory, and tried to install it, it asked for the keys, i entered the keys also, and then it's showing that "initialization failed basic (), pls help me to solve this problem......

    ReplyDelete
    Replies
    1. "and copy the aoe 3 file from rirectx9 to the aoe directory"

      I have no idea what you're talking about there, that is not something you need to do dude.

      Follow these steps!
      1. Install Age of Empires 3 (do not install any cracks after you finish, you just need a serial)
      2. Install The WarChiefs (watch out what pirated version of this one you install, some are broken)
      3. Install The Asian Dynasties (try not to run any of them until you complete all steps)
      4. Update Age of Empires 3 (latest version: 1.14)
      5. Update The WarChiefs (latest version: 1.06)
      6. Update The Asian Dynasties (latest version: 1.03)
      7. Install mod and run the patcher to update (run as administrator)

      Delete
  29. does the update takes a long time

    ReplyDelete
    Replies
    1. O course not. The patcher can download the entire mod in about 10-20 seconds. I you have problems make sure you run the patcher as administrator and make sure your antivirus isn't blocking it.

      Delete
  30. Hey, Mandos I already installed the mod works great. The only problem is my population has the fame(icon), fame has the food(icon),food has the wood (icon), wood has the gold (icon), and the gold has the population (icon). Do you get me? (All of this is on lower left corner). Also,export doesn't show, but I don't know if you already knew that. In addition, did you also remove the top right buttons where it selected your explorer and town center ,that's not showing up either. Other than that the mod is functional. Any Ideas??

    ReplyDelete
    Replies
    1. Go to "Options" and press the "Restore Defaults" button to fix the UI.
      And yes, I removed the two buttons I added for Heroes and Town Centers, they were a bit useless.

      Delete
  31. Very nice works you guys!!! BTW, there are available a Spanish translation? If it is not, I offer my help to create one...

    ReplyDelete
  32. Hey,i have a question about the mod..
    i used to play it 2 months ago..i had no problems..i played it normaly..but then one day i open the mod patcher..and it said that it could not contact master server..then i came here i download another mod patcher..install it correctly and now i get an error in the patcher that says:ERROR:Could not lock files(are you playing age3y.exe?).
    if you can give me a hand here what to do.

    ReplyDelete
    Replies
    1. Run as ADMINISTRATOR!
      And make sure the antivirus isn't blocking the patcher.

      Delete
    2. ok i did it it wasnt that :P
      i went to downloads and installed the latest mod patcher and that fixed the prob..ty anyway :) the mod is awesome

      Delete
  33. Question and I have a feeling its been asked before, but are the maltese/knights of st. john a playable civ in single player? if it is I am not seeing it.

    ReplyDelete
    Replies
    1. They are not playable in Skirmish, no.

      Delete
  34. This comment has been removed by the author.

    ReplyDelete
  35. Correction: THIS MOD IS FUCKING AWESOME. That is all.

    ReplyDelete
  36. please help me donload it onto steam :/. im having so much trouble

    ReplyDelete
    Replies
    1. Judging by the way you wrote your message I am completely certain you do have a hard time making it work.

      You have tutorials here, use them! Although I fear no tutorial in the world might help you...

      Add me on Skype if you need help, at this ID: mandos-rex.

      Delete
  37. Hi. Installed the mod and played around with it for a bit. I noticed while playing the first campaign the resource numbers are wrong, they state much higher numbers (1000+) when my resources are actually really low (~50).

    Any idea what causes this and how I could fix it?

    ReplyDelete
    Replies
    1. Look on the right side of the blog, you see what it says?

      "If you have problems with the UI not displaying resources correctly go to "Options" and press the "Restore Defaults" button!"

      If you have problems look around people!!!

      Delete
    2. you can 'please enter mexico, union and confederate, I like epic battles.

      Delete
    3. I believe you can revolt into Mexico, no playable civ for them.

      Delete
  38. you can join this mod http://aoe3.heavengames.com/downloads/showfile.php?fileid=1289&ci=64b80d2ef767b9a4b124c3be11eefb70YToxOntpOjA7YToyOntpOjA7czoxNDoiU2VhcmNoIFJlc3VsdHMiO2k6MTtzOjUyOiJsaXN0ZXIucGhwP3N0YXJ0PTAmYW1wO3NlYXJjaD1Ob3J0aCBBbWVyaWNhbiBUaGV

    ReplyDelete
  39. This comment has been removed by the author.

    ReplyDelete
  40. Hai Congrats for the Greaaaaaaat Mod becoz of which i still continue to play aoe 3..
    few months earlier i got it worked perfectly, but now when i installed manually it is simply normal with few additions. the main thing i found is i could not construct a command post with US civilization as u said saloon is replaced but villager shows only saloon and i could not find US home town. i have installed it thrice exactly as mentioned in the installation guide.. i have not found post office or bakery either... i could construct command post with some of the civilizations but not with USA.. is there any problem with the manual installation or did i made any mistake

    ReplyDelete
    Replies
    1. Yes, many changes have been made in the last updates.
      First of all, the Lumber Camps and Bakeries were removed while Houses can now train livestock and the Livestock Pen can now produce food like a bakery, though the Livestock is now a Native only building. Oh, and the Church can now produce coin if you research a tech.

      The Americans can only build the Saloon, not the Command Post because the Saloon feels more american and thus I left it there. The Post Office has been also removed and the Consulate has been added for the Americans.
      Also please note that I'm not working on the Americans anymore, several reasons for that but the main one is that I can't get them to work as I want.

      What do you mean by "i could not find US home town" ??? If you refer to the American civilization and home city then go to the "Select a Home City" window and look for Philadelphia.

      Delete
    2. Thank you Mandos... i thought i was doing some mistake with the installation... now relieved with your reply...:-)
      and about the US home town i thought it is available as another civilization...so got confused..sorry..
      i still find lumber camps in campaigns...
      there is a card which upgrades command post to command center in the philadelphia home town...with which i got confused...please check with that
      thank god that it was working fine for me but mainly caught up with the command post card......
      thank you again for the really greaaaaaat modd.. really loved it..a big thanks ...

      Delete
    3. Yes, I think I left the Lumber Camp for Malta right? Nothing big, makes it look kinda like a unique civ thing.

      As for the Command Post card in the US home city, maybe I'll remove it, dunno.

      Delete
    4. Hai Mandos
      Yeah lumbar camps in malta only
      I donno what it is called a glitch or bug
      I found that in TAD campaigns could not create the armies from consulate i get exp points for creating the armies from consulate and if created gets a single unit with high attack around 150 to 250 but works fine in skirmish

      If possible can you add asian civs to consulate mainly for ronin and elephants

      Delete
  41. Hey
    stupid Question
    where do the files for the german translation go?
    greets!

    ReplyDelete
    Replies
    1. Age of Empires 3/data

      Or if you're using the Steam version...

      Age of Empires 3/bin/data

      It should ask you to replace an existing file, that's how you know its in the right place.

      Delete
  42. Why the patcher take too long to update? i mean it always checking for updates... any help?

    ReplyDelete
    Replies
    1. Yeah, don't run it every time you want to play...
      Just run the game normally without it and the mod will work. Only run the patcher like once a week.

      Delete
  43. do i really have to update via the online patcher? i just downloaded the mod and instld. the patcher cannot connect to the master server. can i run it without updating?. i mean, is the mod file i've just downloaded, up-to date?

    ReplyDelete
    Replies
    1. No it is not, a quick look around the blog and you would have seen that the patcher from the 5.4 installer is outdated and does not work anymore.

      Instead, download the newer version, put it inside your game's folder (replace the old one) and run it as admin, it should update without a problem.
      Please note the it might take a while the first time you run the new patcher.
      https://www.dropbox.com/s/7360e1kdq6yw3vl/AoE3ImpModPatcher.exe

      Delete
  44. thanks mate, it's working properly now. i tried running without updating,it was a mess corrupted UI and shit. everything is in place now.

    ReplyDelete
    Replies
    1. If the UI has problems go to Options and press Restore Defaults.
      That is also all over the blog. Glad it works. Have fun.

      Delete
  45. I have an issue with the Consulate. I noticed it in the TAD campaign. When I have a secondary objective to choose an ally from Consulate it never completes and I notice that I can't train armies from the consulate, they just don't appear, or once, only a silhouette of a single soldier dying continuously appeared.

    ReplyDelete
  46. Ok one more question how do I install the german translation? Thanks again! :)

    ReplyDelete
    Replies
    1. put it to data and replace the old file

      Delete
  47. Hello Mandos

    your mod is the greatest

    can you make for Heroes [all heroes,explorer like asians indians and europeans]
    can make it that they can build 2 factorys adn all a saloon or commandpost because i hate it when Indians dont have strong mercenary but the others

    sry for my bad english
    i hope you can make or tell me how i can make

    ReplyDelete
    Replies
    1. Oh, you mean American Indians? It is impossible for them to have random mercenaries like everyone else but I have tried to make up for that with powerful techs in the Council's Hut and cheap units in the Embassy.

      Delete
    2. and can you make for the heroes this with the factorys it better when all can build factorys with heroes

      Delete
  48. i saw a bug i cant build the native embassy and cant train cree couruer the boys or however it calls or francias couteliers

    ReplyDelete
    Replies
    1. Only Native Americans (Indians as you called them) can now build native embassies, they also have more uses now.

      Delete
  49. I've installed it, but when I played. can not because they have to enter serial number.can you help me with crack or i must insert teh serial number?

    ReplyDelete